Issues with logins and password reset
Incident Report for Governor
Resolved
This issue has been resolved. Dashboard logins and password resets functionality has been restored.
Posted Oct 18, 2017 - 21:57 UTC
Investigating
The Governor dashboard is experiencing login and password reset issues due to issues with external authentication services.
Posted Oct 18, 2017 - 21:48 UTC