Adobe creative cloud issues
Incident Report for Governor
Resolved
This incident has been resolved.
Posted Dec 21, 2018 - 20:54 UTC
Identified
The adobe creative cloud is currently experiencing an outage. This outage is affecting image editing in the media module. We will continue to monitor the situation and provide updates on the status of this issue.
Posted Dec 20, 2018 - 18:04 UTC
This incident affected: Management dashboard.