We are investigating increased error rates in some customer websites
Incident Report for Governor
Resolved
Increased error rate for some customer websites has been resolved.
Posted Oct 17, 2016 - 08:09 UTC
Investigating
We are currently investigating this issue.
Posted Oct 17, 2016 - 08:05 UTC