Governor.io domain DNS issue.
Incident Report for Governor
Resolved
We have resolved the issues impacting governor.io DNS domains and related functionality. All platform functionality is now normal.
Posted Feb 20, 2018 - 14:14 UTC
Identified
We are experiencing issues with the DNS servers resolving Governor.io domains.
Posted Feb 20, 2018 - 12:24 UTC