Investigating issue with new site creation subdomains
Incident Report for Governor
Resolved
This incident has been resolved.
Posted Jun 04, 2018 - 16:21 UTC
Update
We are continuing to investigate this issue.
Posted Jun 04, 2018 - 16:20 UTC
Investigating
We are currently investigating this issue.
Posted Jun 04, 2018 - 15:05 UTC
This incident affected: Management dashboard.