Login issues
Incident Report for Governor
Resolved
This incident has been resolved.
Posted Jul 18, 2018 - 12:43 UTC
Investigating
We are currently investigating login issues preventing users from logging in.
Posted Jul 18, 2018 - 12:29 UTC
This incident affected: Management dashboard.